ISP Fiber upgrade
Resolved
Aug 22, 2025 at 12:00pm UTC
Our ISP will be performing an upgrade on our fiber installation. The downtime will be limited but the actual disconnection time is still unknown.
Affected services
Resolved
Aug 22, 2025 at 12:00pm UTC
Our ISP will be performing an upgrade on our fiber installation. The downtime will be limited but the actual disconnection time is still unknown.
Affected services